Excel. Кроссворд с проверкой

Данная практическая работа является проектом. Работа требует довольно много времени на выполнение. Возможны межпредметные связи, создание кроссвордов по различным предметам. Теперь запаситесь терпением!

Этап 1.

Прежде, чем приступить к выполнению работы, необходимо определиться с темой кроссворда (если он тематический) и с вопросами, на основе которых будет строиться каркас нашего творения. В качестве примера, я возьму тему «История вычислительной техники» и выберу вопросы:

  1. Основоположником отечественной вычислительной техники является…  (Лебедев)
  2. Разработал прямоугольную логарифмическую линейку (Бисарк)
  3. Один из конструкторов ЭНИАК (Эккерт)
  4. Праотец современной архитектуры компьютеров (Нейман)

(Для примера достаточно)

Этап 2.

Создаем новую книгу в Excel и с помощью инструмента «Границы» создаем контур нашего кроссворда. Можем выбрать «Все границы» и получить выделенные ячейки с предустановленной толщиной границ.

excel1

Если выберем «Другие границы», то сможем задать свою толщину линий. (Прежде чем устанавливать границы, ячейки нужно выделить)

excel2

 Продолжаем с остальными словами, точнее с ячейками для наших слов. В итоге должны получит следующую картинку (шрифт 18 пт):

excel3

В дополнении буквы можно выровнить по горизонтали и вертикали

Итак, каркас готов, можно двигаться дальше.

Этап 3.

Переименуем лист на «Кроссворд»

На данном шаге мы создадим дубликат нашего листа и назовем его «Ответы». Кликаем правой кнопкой мыши по ярлычку с названием листа и в контекстном меню выбираем «Переместить/скопировать»

excel4

Далее следуем меткам на изображении:

excel5

Переименуем созданную копию «Кроссворд (2)» в «Ответы» и удалим слова из ячеек на листе «Кроссворд». В итоге на листе «Кроссворд» только сетка кроссворда, на листе «Ответы» — сетка кроссворда с заполненными ячейками.

Этап 4.

Добавляем на лист «Кроссворд» вопросы: ВСТАВКА — НАДПИСЬ. Форматируем блок с вопросами. Обозначим в кроссворде цифрами номера вопросов и зальем ячейки цветом. Вот что у меня получилось:

excel6

Этап 5.

Теперь самое интересное, запрограммировать автоматическую проверку кроссворда

На листе «Ответ» создадим табличку, в которой будет отображаться, отгадано слово или нет. Если слово отгадано — пишем единицу, если нет — ноль.

excel7

Запишем в ячейки, в столбце ОТВЕТ, формулы, которые бы автоматически ставили нолик или единицу.

Принцип следующий: если ячейки на листе «Кроссворд» совпадают с ячейками на листе «Ответ» соответственно, то запишем единичку. иначе —  нолик.

=ЕСЛИ(И(D6=Кроссворд!D6;Ответы! E6=Кроссворд!E6;Ответы!F6=Кроссворд!F6;
Ответы!G6=Кроссворд!G6;Ответы!H6=Кроссворд!H6;
Ответы!I6=Кроссворд!I6);1;0)

Как мы видим, у нас сложное условие. Союз И в формуле говорит о том, что условия в скобках должны выполнятся все, без исключения.

Этап 6.

После того, как ячейки в столбце ОТВЕТ заполнены, сделаем последний штрих.

На листе «Кроссворд» выведем счетчик отгаданных слов. Для подсчета используем следующую формулу:

=СУММ(Ответы!N5:N8)

С помощью функции СУММ суммируем ячейки из таблицы на листе «Ответы» столбца ОТВЕТЫ.

excel8

Осталось скрыть лист «Ответы». Правой кнопкой мыши кликаем на ярлычке «Ответы» и выбираем СКРЫТЬ.

Можно в дополнении скрыть сетку листа ВИД — снять галочку с СЕТКА

Спасибо за внимание!

1 Звезда2 Звезды3 Звезды4 Звезды5 Звезд (10 голос, значение: 4,20 из 5)
Загрузка...
Вы можете оставить комментарий, или ссылку на Ваш сайт.

5 комментариев к записи “Excel. Кроссворд с проверкой”

  1. tа/\gАT:

    я не понял что нужно делать в 5 этапе?!

  2. tа/\gАT:

    и куда это вставлять?

  3. tа/\gАT:

    а все все! уже понял! =)

  4. Надежда:

    непонятно, что куда вставлять на этапе 6

Оставить комментарий

Антибот *